On Mon, 17 Aug 2009 07:48:20 +0100 Alan Cox <firstname.lastname@example.org> wrote:
Those names are wrong.
They're wrong because they are the spinlock-specific variant. What are
we going to call the mutex_lock-specific variant?
tisn't. radix-tree, rbrtee, idr, list_head, prio_tree, flex_array -
none of them use that convention.
It fixes naming mistakes. Long-term it is the correct thing to do.
Best to do it now before we get more callers.